Plumbing Zone - Professional Plumbers Forum banner

1 - 6 of 6 Posts

·
Banned
Joined
·
8,808 Posts
Discussion Starter #1 (Edited)
OK I'm not at all very good at diagnosing a problem with commercial water heaters, I'd just not even work on them if I had a choice, but here is a question, need possible clues on what the problem could be on this heater, get to the job site, heater is fairly new, the temp on the heater upon arrival was 80, the sentinel was stuck on ECO and would not go into main valve light up, now to get it to reset and proceed though entire sequence we had to power off the Sentinel unit, after that it fired up, without a glitch, reached it temp of 140 and burners shut down, ran water to cool it down to test it and it cooled about 10 degrees less and then fires right back up, no glitches. Now I was not able to get the heater to repeat the problem, I was told that if the damper fails to open up, this will cause it to not fire, and if the damper is not it then it could be the sentinel brains starting to malfunction, looking for your thoughts, I told them to call when it happens again, I need to see it damper is in fact open or closed.
 

Attachments

·
Banned
Joined
·
8,808 Posts
Discussion Starter #3
Thanks KTS, so if the relay is failing, and upon resetting the sentinel, off and on again, this will reset the damper relay?
 

·
Chase Plumber
Joined
·
289 Posts
I would presume the contactors are bad in the relay, if the relay is the problem. I've never really worked on gas fired w/hs much. Everyone uses electric w/hs here mostly.
 

·
Banned
Joined
·
3,806 Posts
Thanks KTS, so if the relay is failing, and upon resetting the sentinel, off and on again, this will reset the damper relay?
Temporarily, but the problem will reoccur because the relay itself is bad. Here Rheem has a factory tech that handles problems like this, I don't know if they do in Oregon, but I would definitely contact the factory rep for your area.
 

·
Banned
Joined
·
8,808 Posts
Discussion Starter #6
I called Ruud when I was on site, got a female rep, very unpleasant chat, sorry but having to talk a a female rep I did not want, she told me it could be a problem with gas being supplied to the heater, said no way to tell without in malfunctioning while on the phone, this was 1 1/2 days ago, have not got a return call for this same problem yet, still waiting for the call.
 
1 - 6 of 6 Posts
Top