Plumbing Zone - Professional Plumbers Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, we just moved to a new place with the following setup: Buderus G115/5 boiler (with Tekmar 256 OTR and Honeywell Aquastat L8148A 1124). SuperStor 80G indirect water heater. 2 Air handlers. Grundfos circulator. There are three Taco valve zones (1 for the SuperStor, 1 for AH in attic and 1 for AH in Basement). 3 Nest thermostats. I am no expert by any means but I noticed a few things that don’t make sense to me:

1. Tekmar’s temperature sensor is connected to the RETURN line, not SUPPLY like I would expect. Is this normal?

2. Aquastat has only upper limit control and is set to 180. With this temperature on the Aquastat, the Tekmar and the circulator do not behave the way I would expect. Basically when there is a call for heat from the thermostats, the taco valves open sending a signal to the Tekmar, Tekmar then displays “Boiler Demand” BUT it does not trigger the circulator and/or boiler. I expected the boiler demand on the Tekmar to trigger the circulator and the boiler (if temperature is not hot enough). Only the "burner icon" on the Tekmar triggers the circulator and boiler to turn on simultaneously. When the Aquastat detects the upper limit temperature, it turns off the boiler and keeps the circulator running. Is this normal (the boiler demand not triggering anything)?

Any info on this set up would be greatly appreciated. Thank you!
 

·
Super Moderator
Joined
·
11,997 Posts
Hello, we just moved to a new place with the following setup: Buderus G115/5 boiler (with Tekmar 256 OTR and Honeywell Aquastat L8148A 1124). SuperStor 80G indirect water heater. 2 Air handlers. Grundfos circulator. There are three Taco valve zones (1 for the SuperStor, 1 for AH in attic and 1 for AH in Basement). 3 Nest thermostats. I am no expert by any means but I noticed a few things that don’t make sense to me:

1. Tekmar’s temperature sensor is connected to the RETURN line, not SUPPLY like I would expect. Is this normal?

2. Aquastat has only upper limit control and is set to 180. With this temperature on the Aquastat, the Tekmar and the circulator do not behave the way I would expect. Basically when there is a call for heat from the thermostats, the taco valves open sending a signal to the Tekmar, Tekmar then displays “Boiler Demand” BUT it does not trigger the circulator and/or boiler. I expected the boiler demand on the Tekmar to trigger the circulator and the boiler (if temperature is not hot enough). Only the "burner icon" on the Tekmar triggers the circulator and boiler to turn on simultaneously. When the Aquastat detects the upper limit temperature, it turns off the boiler and keeps the circulator running. Is this normal (the boiler demand not triggering anything)?

Any info on this set up would be greatly appreciated. Thank you!

 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top