Plumbing Zone - Professional Plumbers Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Hi all, I removed my cable for a good cleaning. I reinstalled the cable and it doesn't seem to be installed correctly, the extra drum cable hits cable end and gets tangled up. I emailed General Wire but got no response and there online instruction conflicts with their animated picture. Can someone please post a picture of the inside of their drum to show how it should look? Thanks !;)
 

Attachments

·
Super Moderator
Joined
·
12,505 Posts
Sorry to hear about the cable issue. I wish I could help, but all I have is a K-60 and a K-50.

Maybe you wound it in there clockwise instead of counter-clockwise or vice-versa.
 

·
Registered
Joined
·
3,351 Posts
I beleive the acnher is the bolt by the end of your cable. Not 100% sure though, I should know, I had a Mini Rooter and used it for years....I hated that machine, that I pretty much erased my memory of it.
 

·
Registered
Joined
·
1,572 Posts
droptopgt said:
Hi all, I removed my cable for a good cleaning. I reinstalled the cable and it doesn't seem to be installed correctly, the extra drum cable hits cable end and gets tangled up. I emailed General Wire but got no response and there online instruction conflicts with their animated picture. Can someone please post a picture of the inside of their drum to show how it should look? Thanks !;)
I'm purely guessing here but try to install the cable the opposite way you did now. For instance, if you installed it clockwise, try counter clock wise. I'm not at all familiar with cable installation on General machines.
 

·
Registered
Joined
·
3,351 Posts
General says to make sure you make a full rotation before clamping down on the anchor. Looks like your is clamped on the end off your cable. Pull it back out and make a full rotation inside the drum before clamping it down.
 

·
Registered User
Joined
·
8,104 Posts
Cables in backwards, it loads counter clockwise, butting the end of the cable against the piece sticking up behind the anchor. And this is just me, but I put the flat end under the post for a little more tension. I have had them come out and go down a stack.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #13 ·
Finally got around to reinstalling the cable(fractured my hand!). I had it backwards. The cable lays in counter-clockwise and butt the cable end against the flat stop as mentioned. The machine runs smooth now and no tangles, thank you everyone.:thumbup:
 

Attachments

·
Banned
Joined
·
1 Posts
Finally got around to reinstalling the cable(fractured my hand!). I had it backwards. The cable lays in counter-clockwise and butt the cable end against the flat stop as mentioned. The machine runs smooth now and no tangles, thank you everyone.👍
Finally got around to reinstalling the cable(fractured my hand!). I had it backwards. The cable lays in counter-clockwise and butt the cable end against the flat stop as mentioned. The machine runs smooth now and no tangles, thank you everyone.👍
Witch picture is the right way ?
 

·
Reverend, R.S.E., Master Plumber
Nice Head, what’s in the bag?
Joined
·
1,669 Posts
Witch picture is the right way ?
wow you’re 7 years late to the party, and it’s not a Halloween party.
Hat Sun hat Human Fedora Costume hat

and it’s “which” not “witch”.

I going to go out on a limb and guess you missed the part about “posting an intro, before you post in any other forum”?
 

·
Registered
Joined
·
6,841 Posts
wow you’re 7 years late to the party, and it’s not a Halloween party.
View attachment 130552
and it’s “which” not “witch”.

I going to go out on a limb and guess you missed the part about “posting an intro, before you post in any other forum”?

I love you, will you be geh with me?
 
1 - 16 of 16 Posts
Top